fbpx

system-requirements

Here are the requirements for all our products :

  • Windows 10+
  • Mac 10.11+ (including Mac M1, Big Sur, Monterey )

DAWs comptatible :

  • All except Protools (No AAX plugins)